none
How do I change password when connected to Remote Desktop? RRS feed

  • Question

  • Hi,

    I can't seem to find "Change Password" when connected to Windows Server 2012 with Remote Desktop. It's totally missing.

    Thanks.

    Monday, December 10, 2012 4:59 AM

Answers

  • Hello,

    Press CRTL+ALT+END

    this is in essence the same thing as CTRL+ALT+DEL, it will display the login security screen where you can change the password, lock the computer, shut down, etc.


    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Monday, December 10, 2012 5:13 AM
  • Hi,


    I agree with Falcon, you can press Ctrl+Alt+End to change the password for the remote computer. In addition, based on my test, when the password is changed, the session will not disconnect and you need to type the new password the next time you connect to this server.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Tuesday, December 11, 2012 6:21 AM
    Moderator

All replies

  • Hello,

    Press CRTL+ALT+END

    this is in essence the same thing as CTRL+ALT+DEL, it will display the login security screen where you can change the password, lock the computer, shut down, etc.


    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Monday, December 10, 2012 5:13 AM
  • Hi,


    I agree with Falcon, you can press Ctrl+Alt+End to change the password for the remote computer. In addition, based on my test, when the password is changed, the session will not disconnect and you need to type the new password the next time you connect to this server.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Tuesday, December 11, 2012 6:21 AM
    Moderator
  • I know this is an old thread, but my question is pretty much the same.

    I was wondering if there's a user friendly method to change the password.
    Reason why I'm asking, I don't expect users to remember the CTRL+ALT+END combination if they're required to only change their password once every few months.

    In server 2008R2 there was the Windows Security -> Change password.
    Isn't there a similar method for 2012? Or commandline I could run (so I can create a shortcut for users)?

    Kind regards,
    Peter

    Sunday, April 7, 2013 8:11 PM
  • I have to agree, CTRL + ALT + END is not an option if you e.g. have to use "HOP servers" (RDP connection from another RDP session).

    This is quite common scenario, and if user is not local admin, he is not able to reset password as well...

    Regards,

    Jan

    • Proposed as answer by Nico_YQB Monday, August 14, 2017 5:47 PM
    Thursday, May 23, 2013 3:02 PM
  • Hello,

    You can open a command prompt and type CONTROL USERPASSWORDS2 if you have sufficient privileges to access users and passwords MMC.

    Alternatively, try the command net user username newpassword


    Miguel Fra | Falcon IT Services, Miami, FL
    Web Site | Blog


    • Edited by Miguel Fra Friday, May 24, 2013 1:05 AM
    Friday, May 24, 2013 1:03 AM
  • Unfortunately userpasswords2 can't change domain accounts. And I guess "net user * /domain" is rather reset instead of change?

    Friday, May 24, 2013 8:39 AM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)
    Monday, January 13, 2014 11:34 AM
  • We had the same issue. Our workaround has been to create a vbs-script and add a shortcut to this cscript into the redicted startmenu of all users.

    The script:

    Set objShell = CreateObject("Shell.Application")
    objShell.WindowsSecurity

    • Proposed as answer by Peter Elbertse Saturday, January 18, 2014 12:13 PM
    Monday, January 13, 2014 2:35 PM
  • Thanks so much "Peter Elbertse". The VB Script works perfect for password change. Cnt/Alt/Del is for local account password and not to change password on remote server via RDP.
    Tuesday, January 14, 2014 3:36 PM
  • If you want to reset password under RD Web access, you can able to perform that using Password reset option in window server 2012. You can refer further to  this article for more information.

    Hope it helps!
    Thursday, January 16, 2014 6:05 AM
  • HI Team ,

    I am working currently server 2003 via remote but server administrator not accepted my question is how to change administrator password via remotely because my server currently another country . Please help any one ..

    thanks

    Tuesday, March 11, 2014 9:01 PM
  • Hello,

    You can open a command prompt and type CONTROL USERPASSWORDS2 if you have sufficient privileges to access users and passwords MMC.

    Alternatively, try the command net user username newpassword


    Miguel Fra | Falcon IT Services, Miami, FL
    Web Site | Blog


    That sounds easier for users to remember.... O.o

    -=Chris


    • Edited by Progent.CT Sunday, March 16, 2014 9:41 AM
    Sunday, March 16, 2014 9:41 AM
  • Did anyone consider how this would impact RDS users before rolling it out to millions of people?

    Good God, I would  think that after 20 years of doing this you might start getting it right.  I'm not asking for perfections but man, you're trying to roll out something new every 18 months without even fixing the crap in place. 

    People are not going to ride this train all the way into the dirt..


    -=Chris

    Sunday, March 16, 2014 9:44 AM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)

    I like this solution the most !

    Very elegant !!

    Very easy to explain to others !

    • Proposed as answer by Somesh_SN Friday, September 19, 2014 10:46 AM
    Thursday, March 20, 2014 7:55 AM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)

    Great tip! Akward, but it surely works!

    Thanks

    Thursday, April 3, 2014 9:35 AM
  • A easier way is press Win + Aly + End, try it. Works perfect.
    Tuesday, April 8, 2014 8:41 AM
  • I agree, who decides to use "touch screen" UI on a server???
    Thursday, May 8, 2014 7:46 PM
  • This truly shows how bad microsoft is. I mean, seriously, you remove the ability to change the password from the user account interface where it clearly states that you will be able to make changes to your account. What changes can you make from this screen that any user would typically make? The fact that there is even a thread dedicated to this is just irritating.

    Here is a pro tip for ALL microsoft developers:

    Stop reinventing the interfaces

    Second pro tip:

    Since we all know you can't follow tip one, give people the ability to undo whatever it is that you are about to implement that everyone will hate, but you have justified, in your mind "will be super intuitive and user friendly", because you will be wrong about your assumptions, every time.


    Plus, all of the answers are CTRL + ALT + END   ......What about Mac users remoting in????? Just plain stupid UX/UI
    Friday, May 16, 2014 8:51 PM
  • Mac Via RDP for me this works

    CTRL + ALT + Fn + delete

    Thursday, May 29, 2014 3:47 PM
  • Thanks
    • Proposed as answer by gchalmoukis Sunday, January 8, 2017 2:43 PM
    • Unproposed as answer by gchalmoukis Sunday, January 8, 2017 2:43 PM
    Sunday, June 1, 2014 9:43 AM
  • Hi.

    I am in console name HOME. From console Home i connect to Station A with remote desktop. Then I connect to station B from station A again with Remote Desktop.

    Now i want to change station B password. How i can do it?

    When I press ALT+CTRL+END the change password for station A appear.

    Please help me.

    Thanks.

    Friday, August 8, 2014 12:53 PM
  • Not exactly a "simple" way, but you can use (in Windows 2012 R2, no Active Directory):

    • Start Screen
    • Control Panel
    • Change Account Type
    • Double-Click on the User Account you want to change
    • Click Change the password

    Julien

    • Proposed as answer by net_user Monday, August 1, 2016 9:59 AM
    Tuesday, August 12, 2014 1:14 PM
  • Mac Via RDP for me this works

    CTRL + ALT + Fn + delete


    Ctrl + Alt + F'ing + Delete.... I Love IT!
    Thursday, August 14, 2014 8:28 PM
  • We had the same issue. Our workaround has been to create a vbs-script and add a shortcut to this cscript into the redicted startmenu of all users.

    The script:

    Set objShell = CreateObject("Shell.Application")
    objShell.WindowsSecurity


    By far the best option. I don't think most realize how simple this is. Copy the above two lines into a text file, rename to .vbs and put the shortcut in the location of your choosing, i.e. start menu or desktop, etc...
    Thursday, August 14, 2014 8:29 PM
  • Greate this is works for me Win + Alt + End
    Tuesday, August 26, 2014 9:25 AM
  • I'm happy to see that someone realises you don't want users to remember long key-strings and users simply want to click on a button :)
    Tuesday, August 26, 2014 9:32 AM
  • I had access to a Windows Server 2012 R2 using RDP in a HyperV VM så ctrl+alt+end didn't work. It was "caught" by the VM's OS.

    Using your approach with the OSK works well. :-)

    Thank you.

    Henrik Kim

    Wednesday, September 3, 2014 7:30 AM
  • Not only Mac users but what about remote administration of multiple machines?!

    Anybody ever remote desktop through multiple machines? Where does your Ctrl+Alt+End key combination (that's not written anywhere on screen like an actual intuitive interface should) invoke the security screen? On your bounce box or the destination box that you actually want to change your password on?

    Ctrl+Alt+End does nothing on my 2012 R2 system and Ctrl+Alt+Del is oh so helpful in saying "To use the commands available when you press Ctrl+Alt+Del, click your user tile and choose an option"

    After some searching I found 2 workaround solutions at
    http://superuser.com/questions/492856/how-can-i-send-a-ctrlaltdelete-through-remote-desktop-in-windows-8

    1.) On the first RDP session bring up the on screen keyboard applet (Run -> osk), and click on the second (inner) RDP session, then click back to the keyboard and press CTRL ALT END with your mouse, which should send CTRL ALT END to the second RDP session - Thanks to user Matthew Lock

    2.) Press Ctrl+Alt on your physical or on screen keyboard in your first session and click Del on the on screen keyboard in the second session. - Thanks to user Salsengsangma

    I fully agree about what these fools get up to. I mean there's the obvious who the hell wants a "Start Menu" that takes over the whole screen? I want to see the stuff I have open while I'm choosing something else to open!@#!@# My remote server, rack of servers or cluster of VMs are not damn touch screen phones! At least there's some good options when you right click the Start button. Yay Microsoft!
    Thursday, September 11, 2014 1:14 AM
  • :) that was cool! Thanks Richard!

    Raja

    Monday, January 19, 2015 4:51 AM
  • OK.. Yes, CTR,ALT+END will open up the change password dialog if you have a rdp session from a real session.

    I work in a VDI environment where we connect through Wyse Terminals to an RDP session into our regular workstation VM's.. We then have to remote from there to a server, which causes the CTR,ALT,END to be picked up by our workstation (because it's a remote session itself)....

    What I had to do was open the on-screen-keyboard, hold CTR and ALT on the physical keyboard and click DEL in the On-screen keyboard... opens up the user pw change dialog.


    Hey...I dont think that light is the end of the tunnel?!

    • Proposed as answer by Mayank431 Monday, March 2, 2015 6:38 PM
    Thursday, January 22, 2015 2:53 PM
  • Run the following oneliner:

    Powershell -noprofile -nologo -noninteractive -command "(new-object -ComObject shell.application).WindowsSecurity()"

    • Proposed as answer by totallycool24 Friday, April 24, 2015 3:08 PM
    Friday, February 20, 2015 10:54 AM
  • Works for me !! Thanks Megatronn !!
    Monday, March 2, 2015 6:43 PM
  • I found this does not work if remote desktop from another remote desktop. Richard Hlavienka on screen keyboard method works in the scenario.
    Wednesday, March 25, 2015 3:26 PM
  • CTRL-ALT-END doesnt always work and the on screen keyboard just ticks people off

    Peter's script is the best solution

    Wednesday, April 8, 2015 3:31 PM
  • This totally works in Server 2012.  Especially when your RDP session is like 2 levels deep.

    Powershell -noprofile -nologo -noninteractive -command "(new-object -ComObject shell.application).WindowsSecurity()"

    Thanks.


    Friday, April 24, 2015 3:09 PM
  • Hi,

    Just want to confirm, the question on hand is "while connected to Remote Desktop". Pressing CTRL+ALT+DEL will login security screen from local machine, not on remote machine.

    Regards

    Wednesday, April 29, 2015 1:54 PM
  • Hi,

    I can't seem to find "Change Password" when connected to Windows Server 2012 with Remote Desktop. It's totally missing.

    Thanks.

    I am in the same situation where basically I am jumping from 1 server to another which is a Jumpbox and then I can log on to the third server.

    Machine 1(My Laptop) -> Machine 2(JumpBox) -> Machine 3 (Machine which requires the password change)

    Now if I press the Ctrl + Alt + End, I see a Windows Security for the Machine 2(Jumpbox) whereas I am trying to change the password for the Machine 3. Now using OSK and doing (Ctrl + Alt on physical keyboard) and click the Del on OSK to get the Windows Security which works but it's a way more tedious than pressing Ctrl, Alt Del.

    Has anyone found another solution please let me know.


    Anurag Shukla

    Microsoft Certified Professional| Microsoft Certified Technology Specialist (ConfigMgr)

    This posting is provided 'AS IS' with no warranties or guarantees, and confers no rights.
    My Blog


    Please remember to click Mark as Answeron the post that helps you, and to click Unmark as Answerif a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, May 6, 2015 11:46 AM
  • Old thread, but I'd like to add my $0.02.

    If you daisy chain your RDP sessions (login to server1, then RDP to server2), you need to press ctrl-alt-end on server1 to initiate the command on server2.

    If you hop to 3 computers, it gets even weirder.

    Scenerio: Login to server1, RDP to server2, then RDP to server3.  Server3 is 2012 and you need to change your password there.

    Solution: In the Server2 session, bring up OSK (just type OSK from the run or search box, or if on 2012 just type it anywhere on the metro interface).  press ctrl-alt-end using the OSK on server2 (use the on screen keyboard, not your physical keyboard).  This will bring up the password change dialog on server3.  Switch to that RDP session to change your password.

    Maybe Microsoft will bring back the "windows security" application from Windows Server 2008 R2.  Then we won't need this on screen keyboard nonsense.

    Friday, June 5, 2015 1:28 PM
  • Brilliant!!! Thank you
    Monday, June 22, 2015 5:04 PM
  • TTTTTTTTTTTTTTHHHHHHHHHHHHHHAAAAAAAAAAAAAANNNNNNNNNNNNKKKKKKKKKKKK YYYYYYYYOOOOOOOOOOOUUUUUUUUUUUU!!! Sorry, I know that was obnoxious, but seriously, I couldn't figure it out. We do have a box in between us and the domain I needed to change the password on so the CTRL+ALT+END did not work.
    Friday, July 3, 2015 9:00 PM
  • Thanks,

    It's worked for me

    Wednesday, August 19, 2015 8:47 AM
  • Thanks for the OSK suggestions...it worked fine...:)

    VT

    Saturday, December 5, 2015 5:57 PM
  • Thanks.  Works great for me too.  As you can't do a Ctrl + Alt + Del on the remote machine.


    Swanl

    Tuesday, January 19, 2016 3:35 PM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)
    Great! works very well for me. we must press 2 keys on the physical keyboard while1 key on OSK, or it will not work.
    Friday, January 29, 2016 3:04 AM
  • works perfectly. thanks

    Friday, July 8, 2016 12:08 PM
  • This is great! I was in nested remote desktops and nothing else was working and this did. Thank you so much! 
    Friday, September 23, 2016 9:28 PM
  • Right Click the desktop, New, Shortcut.  Paste "explorer.exe shell:::{2559a1f2-21d7-11d4-bdaf-00c04f60b9f0}" with NO QUOTES. Click Next, Name your shortcut.  Right click your new shortcut, Properties, Shortcut tab, Change icon.  Browse C:\windows\system32\shell32.dll.  Choose the padlock.  Save.

    This can be copied around to the public desktop of your servers.  I've only tested as an admin, not as a user.

    • Edited by McReno Saturday, November 5, 2016 5:35 PM More info and formatting
    • Proposed as answer by McReno Saturday, November 5, 2016 5:44 PM
    Saturday, November 5, 2016 5:31 PM
  • Thank you so much... 
    Monday, November 7, 2016 10:52 AM
  • See if i am an admin and i changed password of any user and mark it as password change at next login.

     i will not get a prompt to change it before login or entering to the server like We used to do on server 2003 and will not able to change login the server.

    To resolve it i have to uncheck change password at next login and have to use ctrl+alt+del.

    What is the other way to change password before login ??

    Wednesday, December 28, 2016 11:18 PM
  • Straight up CTRL-ALT-DEL works for me on Mac (extended / full Mac keyboard).

    None the less, the VB Script option from Peter Elbertse is the best. Make that VBScript, call it with a .cmd file and then put a shortcut to that on everyone's desktop. Then they have a link they can click to reset password, which is far better than any keyboard shortcut for the average user. 

    Friday, January 27, 2017 2:19 AM
  • TY sir.. I never would of thought of that. Works as advertised. 


    Wednesday, February 8, 2017 6:03 PM
  • Thank you!  

    RDP through jumpbox for security to then RDP to another machine that I can login to for a secondary acct used for security purposes.  Short of logging out of main pc login and thus having to close all my apps and cause major disruption.  

    If you're double RDP'ed don't waste time with all the other 'solutions'.  This is the only thing that works.  

    Monday, February 20, 2017 8:24 PM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)

    Worked...  :) Thanks.. Not even thought about this....

    Thank You Sreejith

    Friday, April 7, 2017 7:18 AM
  • We had the same issue. Our workaround has been to create a vbs-script and add a shortcut to this cscript into the redicted startmenu of all users.

    The script:

    Set objShell = CreateObject("Shell.Application")
    objShell.WindowsSecurity


    By far the best option. I don't think most realize how simple this is. Copy the above two lines into a text file, rename to .vbs and put the shortcut in the location of your choosing, i.e. start menu or desktop, etc...

    The best answer is usually ctrl alt end, but when your in a citrix session using a rdp in a rdp things get tricky :)

    The vbs is definititely nice, but nowadays we are in the world of powershell :

    $shellobject = New-Object -ComObject Shell.Application

    $shellobject.WindowsSecurity()

    Save this as a .ps1 and run it.

    


    Rob Korving
    http://jama00.wordpress.com/


    • Edited by rob1974 Tuesday, April 18, 2017 8:29 AM
    Tuesday, April 18, 2017 8:28 AM
  • Good use of powershell, but the vbscript solution runs faster on my server.  The OSK solution (which I personally find harder to remember) would be necessary when you don't have an 'ongoing relationship' with the server you're trying to run windows security on.
    • Edited by L U Thursday, April 20, 2017 1:37 AM
    Thursday, April 20, 2017 1:30 AM
  • You're a genius, thanks!

    Friday, April 21, 2017 4:57 PM
  • Open Computer Management. Expand Local Users and Groups -> Users. Find your user name and right-click it. Select Set Password. This is where you change your password. 
    Wednesday, April 26, 2017 8:17 PM
  • Nice... thanks from a Mac user :)
    Tuesday, June 20, 2017 1:49 PM
  • Press WindowsKey+R (or get the Run box open) – then type OSK (It will open ‘on-screen-keyboard in your remote-remote session). Or open on-screen-keyboard in different way.
    Then press on your physical keyboard (not on that on screen!!) ctrl and alt keys. Using your mouse tick DEL key on ‘On-screen-keyboard’.
    Works well for me :)

    perfect answer :) .. it works like a charm..
    Thursday, July 6, 2017 8:06 AM
  • We had the same issue. Our workaround has been to create a vbs-script and add a shortcut to this cscript into the redicted startmenu of all users.

    The script:

    Set objShell = CreateObject("Shell.Application")
    objShell.WindowsSecurity


    By far the best option. I don't think most realize how simple this is. Copy the above two lines into a text file, rename to .vbs and put the shortcut in the location of your choosing, i.e. start menu or desktop, etc...

    Superb :)

    Thursday, July 6, 2017 8:09 AM
  • In a case of "nested" RDP (an RDP session in a RDP session), the easiest way I found is SHIFT+CTRL+ALT+END.

    Then, select change password.

    Using CTRL+ALT+END interect on the first RDP session not the nested one.

    • Proposed as answer by Nico_YQB Monday, August 14, 2017 5:49 PM
    Monday, August 14, 2017 5:49 PM
  • We had the same issue. Our workaround has been to create a vbs-script and add a shortcut to this cscript into the redicted startmenu of all users.

    The script:

    Set objShell = CreateObject("Shell.Application")
    objShell.WindowsSecurity

    Perfect, thank you ;)
    Thursday, October 26, 2017 7:26 PM
  • On Nested RDP sessions, that did not work for me on the enterprise 2012 R2 system I was nested into.  But I did find and use this solution:

    • Right-Click Start , Run, “OSK” to invoke the On Screen Keyboard
    • Hit Ctrl+Alt on your physical keyboard, then Del key on the On Screen Keyboard
    • Then minimize the OSK to see and use the Change Password function

    I found it in this article:

    http://rajdude.com/blog/changing-your-own-password-on-a-rdp-session-on-windows-server-2012-r2/

    Thursday, February 8, 2018 12:04 AM
  • This method does not work. CTRL+ALT+DEL will affect your main PC not the RDP. See the on screen keyboard method below.
    Tuesday, February 27, 2018 7:49 PM
    1. Click Start
    2. Type osk (to bring up the on screen keyboard)
    3. Hit enter
    4. Once the on screen keyboard is open, hold ctrl+Alt on your physical keyboard, then click on the del key in the on screen keyboard.
    5. Minimize the on screen Keyboard
    6. Click Change a password.

    It will work 100%  ......

    Tuesday, March 20, 2018 3:13 PM
  • Execllent trick .I was trying in same way but Missed your trick :) .


    Harry Kochar

    Friday, June 8, 2018 11:45 AM
  • Excellent solution!
    Wednesday, November 28, 2018 8:17 AM
  • Thank you for mentioning. I am mssing the ctrl + ALt on physical keyboard. works like a charm
    Monday, July 29, 2019 10:41 PM
  • Awesome!! Save me!!
    Thursday, December 12, 2019 7:02 PM