Windows Deployment Services Error: The service did not respond to the start or control request in a timely fashion.


  • server- Windows server 2008 standard activated Domain controller.

    I have been running a server as a Domain controller, with active directory, DNS, file service, IIS, GP and WDS roles installed and it has run smoothly. last year it started going slow so I removed, and re-added the roles- I added it to a different internal domain, so DNS has stopped working, since doing this I have had WDS, IIS, AD, GP roles working -all seemed to be working fine. Buying a new computer and wishing to add a custom (generalised) windows 7 image to it using WDS, this worked successfully after appending the required drivers to the boot image. I then decided to use WSUS as it would aid reduce WAN bandwidth, (the internet connection is slow and reinstalling all the computers on the network can cause it to go down-which asides from being an inconvenience can harm productivity) I added WSUS 3.0 and tried to access the web interface in IE and could not for obvious reasons (possibly my own fault for not researching it properly beforehand) access a web interface for WSUS 3.0. At the time I had no reason think that WSUS did not have a web interface therefore I proceeded to remove and re-add the ISS and WSUS roles, after a few days playing with permissions and moving files between folders I finally found out there was no web interface. To test if I had correctly setting up WSUS I updated a reference computer successfully using WSUS on port 8530 and was rather please with myself. when it came then to capturing a none generalised version of windows for use on the new computer after installing office MacAfee and various HMRC accountancy tools I discovered the WDS service was not running on the server and did not start upon attempts to manually start it, returning error message “The service did not respond to the start or control request in a timely fashion.”

     I opened services and made sure I hadn’t inadvertently disabled the service, ensured it's dependency’s were enabled on system configuration (couldn’t find TFTP in services), removed and re-added the WDS role all to no avail. I then looked online and found others had been having similar issues. One article I read:

    Suggested that this problem could be due to the port 67 DHCP listener so I tried checking and unchecking the tick box as was recommended by the article,

    I also read a Microsoft article:

    which suggested this problem might be due to .net framework, so I tried to repair .net framework 4.0 and found it could not, returning error message “This update package could not be opened. Verify that the update package exists”, I then tried to remove it through control panel this also did not work,

    Then I came across a forum post:

    Suggesting I could use the NET Framework Cleanup Tool to remove the installations and reinstall every instance again, I did this, again to no avail.

    To sum up I have not had WDS working since installing WSUS but am not sure if removing WSUS would fix the problem or just be even more labour intensive, I do not particularly wish to reinstall the server as this would risk losing the activation, but am also aware this would clean up old AD OU (prevent accidental deletion), and DNS records-post re-adding all of the roles.

    have i missed somthing out, am i being really dumb or is this a genuine problem?

    Sunday, April 29, 2012 8:14 PM


All replies