none
rdpclip.exe not running automatically RRS feed

  • Question

  • Hello,

    i´ve a problem with an 2008 R2 Terminalserver:

    The Clipboard redirection between RDP client and Server does not work.

    It is activated in the RDP Client (Win 7) and the redirection is activated on the TS (RDP 7.1 Host)

    but the rdpclip.exe is not running.

    when I start the rdpclip.exe manually in the TS session it works.

    what can I do to solve the Problem?

    Tuesday, June 14, 2011 9:22 AM

Answers

  • there was no entry like this:

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
    Value: StartupPrograms
    Type: REG_SZ
    Data: rdpclip

    so I created one and now it is working.

     

    Thanks!!!

    • Marked as answer by EFabian Monday, June 20, 2011 2:49 PM
    Monday, June 20, 2011 2:48 PM

All replies

  • Hi,

     

    Please check your client PC and Terminal Server Registry Keys and Values.

     

    You can open RUN, and type “regedit” to open the Registry Ediror.

     

    Is the fDisableClip set to 0 under

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp ?

     

    If fDisableClip is set to 1 rdpclip.exe will terminate, because clipboard mapping is disabled. Check that rdpclip is still listed under Addins

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Addins\Clip Redirector

    Name REG_SZ RDPClip

    Type REG_DWORD 0x00000003


    Technology changes life……
    • Proposed as answer by TIME_WAIT Monday, December 10, 2012 11:12 PM
    Thursday, June 16, 2011 6:08 AM
    Moderator
  • Hi,

     

    The Registry Keys and Values are correct.

    Thursday, June 16, 2011 6:30 AM
  • has no one a Sollution for this?
    Monday, June 20, 2011 10:01 AM
  • Hello,

                     

    Thank you for your question.

                     

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

                     

    Thank you for your understanding and support.


    Technology changes life……
    Monday, June 20, 2011 10:26 AM
    Moderator
  • Please check the following:


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
    REG WORD: fDisableClip  is set to 0

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\RDPWD
    REG WORD: fDisableClip is set to 0

    Verify that the following registry values are set to "rdpclip"

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\AddIns\Clip Redirector
    Value: Name
    Type: REG_SZ
    Data: rdpclip

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
    Value: StartupPrograms
    Type: REG_SZ
    Data: rdpclip

    Make sure the policy is not enabled:
    Computer Configuration --> Admin templates --> Windows Components ---> Terminal Services--Terminal server -Device and Resource redirection ---> "Do not allow clipboard redirection"

     

    Let us know if that helps.

     


    Sumesh P - Microsoft Online Community Support
    Monday, June 20, 2011 2:22 PM
    Moderator
  • there was no entry like this:

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
    Value: StartupPrograms
    Type: REG_SZ
    Data: rdpclip

    so I created one and now it is working.

     

    Thanks!!!

    • Marked as answer by EFabian Monday, June 20, 2011 2:49 PM
    Monday, June 20, 2011 2:48 PM
  • I am using windows xp machine and rdpclip is not running. I have tried running it manually but still it is not working. rdpclip process doesn't even start.



    I have checked the following entries in the regedit:-


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
    REG WORD: fDisableClip  is set to 0
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\RDPWD
    REG WORD: fDisableClip is set to 0
    Verify that the following registry values are set to "rdpclip" 

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\AddIns\Clip Redirector
    Value: Name
    Type: REG_SZ
    Data: rdpclip

    Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
    Value: StartupPrograms
    Type: REG_SZ
    Data: rdpclip



    all ok but still not working anything else I can try?

    Thursday, March 19, 2015 3:45 PM