Slow login with RDWeb applications and RemoteApps RRS feed

  • Question

  • Hello,

    I'm having a problem with a newly created 2008 R2 RDS Farm. Full desktop logins are fast for remote users (under 10 seconds), but RemoteApps and RDWeb apps take about 30 seconds to load (once loaded, subsequent apps load in 2-3 seconds). The details button is greyed out for about 25 seconds while waiting for the app to load and then when it is finally becomes enabled, the app loads in about 3 seconds.

    The RDS setup consists of:

    1 Gateway server
    1 Connection Broker/License server
    2 Session Host/RDWeb servers

    I have tried the following:

    -Unchecking "Bypass RD Gateway server for local addresses" under the session host settings in RemoteApps manager on both session host servers
    -Disabling UAC on all servers (oddly enough this seemed to increase the login time)
    -Disabling client device redirection

    Nothing has improved the speed. Any other suggestions? Thanks

    Thursday, October 6, 2011 9:00 PM

All replies

  • Hi,


    Thank you for your question.


    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.


    Thank you for your understanding and support.




    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 7, 2011 7:52 AM
  • Hi,

    What options do you have selecting via the mstsc client compared to those for the remoteapp?

    Can you save the connection settings from mstsc for the desktop connection and then compare that to a rdp file created via RemteApp Manager?

    Are there any differences?


    Friday, October 7, 2011 8:07 AM
  • Thanks Arthur, I appreciate your response and look forward to what you come up with.

    Friday, October 7, 2011 2:12 PM
  • Hi John,

    Thanks for the suggestion. I compared both files and there were a number of differences since they are different types of connections. I edited the remoteapp connection and changed it to be as close as I could to the desktop client, but it didn't seem to make any difference in login time. Here are the originals:

    RemoteApp (testing with the character map) - I removed domain specific info and the signature

    session bpp:i:32
    prompt for credentials on client:i:1
    span monitors:i:1
    use multimon:i:1
    server port:i:3389
    allow font smoothing:i:1
    authentication level:i:2
    full address:s:name.domain.local
    alternate shell:s:||charmap
    remoteapplicationname:s:Character Map
    alternate full address:s:name.domain.local

    Desktop Connection - domain specific info removed

    screen mode id:i:2
    session bpp:i:32
    connection type:i:2
    disable wallpaper:i:1
    allow font smoothing:i:0
    allow desktop composition:i:0
    disable full window drag:i:1
    disable menu anims:i:1
    disable themes:i:0
    disable cursor setting:i:0
    full address:s:name.domain.local
    autoreconnection enabled:i:1
    authentication level:i:2
    prompt for credentials:i:0
    negotiate security layer:i:1
    alternate shell:s:
    shell working directory:s:
    use redirection server name:i:0
    use multimon:i:0

    Friday, October 7, 2011 2:27 PM
  • Hi,


    What OS you are using in your client PC? Make sure your Windows client PC have already installed the necessary updates. If you are using Windows XP or Vista, you can try to install the Remote Desktop Connection 7.0.



    When the remote desktop web access & RemoteApp performance is very slow, is there any particular event log in the Event Viewer?


    Please also check the AV and firewall settings, you can disable the 3rd security software to see whether same issue still exists.


    Technology changes life……
    Tuesday, October 11, 2011 8:23 AM
  • Hi Dollar,

    Thanks for responding. We are using Windows 7 SP1 with the latest updates installed. I haven't tested it with XP yet.

    The only events that are logged on the Session Host are informational:
    -4101 - Winlogon - Windows license validated
    -9003 - Desktop Window Manager -  The Desktop Window Manager was unable to start because a composited theme is not in use

    I had already tried disabling AV and the firewall on the client and AV on the Session hosts as well. That didn't seem to make a difference.

    I disabled the theme service and disabled "Allow desktop composition for remote desktop sessions policy" in the local Group Policy under Computer Configuration, Administrative Templates, Windows Components, Remote Desktop Services, Remote Desktop Session Host, Remote Session Environment.

    This has helped as I went from about 28-32 seconds down to about 20 seconds for a login. So we are going in the right direction. Any other suggestions to decrease the login time?


    Tuesday, October 11, 2011 6:28 PM
  • We are having the exact same issue. Same setup. We have both XP and win 7 clients. Both are taking 30 secs to open the first app. Subsequent apps are 2-3 secs.
    Friday, October 14, 2011 3:25 AM
  • I am having the exact same issue with my setup as well.  I have very powerful server with plenty of RAM and it takes between 10 and 20 seconds to launch my first app, but after that it is almost instant.  I understand there there would be a small delay but it does seem kind of long for that initial app launch.


    Monday, October 17, 2011 11:19 PM
  • Hi,

    My user logins in RDS take around 15 seconds so I've expected that there will always be that delay on the first Remote Desktop or Remote App connection.

    That said if you should time a user login for a Remote Desktop Connection against a Remote App connection, in my environment they are the same time.

    If the delay is of a major issue I’d suggestion looking to enable Single Sign on and then launching you Remote App LOB as part of the users start up to insulated them from the slowness. This is something I haven’t done yet but have considered.


    Tuesday, October 18, 2011 11:15 AM
  • Still no luck (back to about 30 seconds). Any other ideas?
    Wednesday, October 26, 2011 10:16 PM
  • Hi,

    I thought you might like to know that I am having similar problems with the setup at the school I work for.  We are using Server 2008 R2 SP1 with Windows 7 SP1 clients.  We have 2 terminal servers setup as a farm and even internally the delay experienced after the user enters their credentials and clicks "Login" is over 1 minute, however this only happens for the first user of the day and all subsequent logins are quite speedy.  There is a delay of about 10 seconds while the first app opens, but this is normal I believe.

    I have logged this with Microsoft and they have been looking at it for a few weeks now, but still haven't found the answer.  I think it could be an IIS problem similar to the delay experienced for Sharepoint 2007 users where IIS goes to sleep when not used for a few hours.  With Sharepoint you could get around the problem by installing a wakeup agent on the server and setting it to run before the users started to connect, but I don't think there is one for RDWeb.  We didn't have the problem before we upgraded to 2008 R2, so it must be a new "feature" or something.

    I will let you know when Microsoft finally find a fix for us.


    Tuesday, November 8, 2011 2:09 PM
  • Thanks for the info StBernards. I'll be curious to see what Microsoft comes up with. I've been beating my head against a wall for over a month now on this one.

    Tuesday, November 8, 2011 6:28 PM
  • Hi,

    I have the same problem.

    4 RDS server Windows 2008 R2 SP1 (HP Proliant DL 360 G5 and G7)
    1 Broker   / RDGW / Rdweb

    Logging via mstsc or rdweb (Remote Desktop) takes 45 seconds.
    It is very frustrating.
    Previously, we had Citrix (CAG) was  very fast.



    • Edited by Faeq Sediqi Friday, November 18, 2011 3:56 PM
    Friday, November 18, 2011 3:56 PM
  • Hi,

    Same setup, same problem here.


    Saturday, November 19, 2011 10:30 AM
  • I have been having the same issue - external Remote apps take up 45-65 sec on a Win7 pc and about 14 sec total on a Winxp machine.


    The Win7 machine is a personal home Win7

    The WinXp i connect to domain and gpupdate then removed from doamin back to a workgroup and took it home


    The speed difference is night and day - I downgraded the RDP 7.1 to 6.1 and it did login about 5 sec quick but not near 14sec total. So messed with secpol.msc under security settings and no luck with the Win7 yet.

    The WinXP machine had to leave on RDP 6.1 and change secpol.msc->send Lm & ntlm use ntlm v2 security for the XP machine to even connect to the TS Gateway and it's its warp speed fast.

    Needless to say remote apps with Win7 external is just painful slow - internal it is quick. Getting closer but still no answer.





    Monday, November 21, 2011 10:55 PM
  • Hey Guys,

    Have you checked the RemoteApp Sources in the Remote Desktop Connection Manager ? Make sure all of the sources are reachable or you will have delays when login in.

    (it fixed the delay problem for me)



    Tuesday, December 6, 2011 1:59 PM
  • Hi,

    Please could you explain this in more detail?  I am using 2008 R2 so I don't have a Remote Desktop Connection Manager.  I have Remote App Manager, Remote Desktop Gateway Manager, RD Services Manager, RD Session Host Configurator and RD Web Access Configuration, but I can't see a link to Sources in any of them.

    Many thanks

    Wednesday, December 7, 2011 12:14 PM
  • Hi,

    It's found here http://technet.microsoft.com/en-us/library/ee216756.aspx

    Make sure you're TS Web Access Computers group is correct.

    If the source is correct check out http://technet.microsoft.com/en-us/library/ee891251(WS.10).aspx I get a lot's issues with wmi/com breaking after Windows Updates

    Update : You might also find this useful http://social.technet.microsoft.com/wiki/contents/articles/5974.aspx



    • Edited by John Grenfell Thursday, December 8, 2011 9:19 AM added wiki link
    Wednesday, December 7, 2011 12:27 PM
  • After months of battling with this, I'm can't push it back any further and have to roll it out to my end users with the delay.  Thanks for all the suggestions so far, but unfortunatley none of them have helped in my case. Looks like a number of people share in the issue so let's keep this thread going and try to hunt down a solution.

    Wednesday, December 21, 2011 9:17 PM
  • There are really 2 delays when it comes to RemoteApp programs.


    The first is the delay to login to the session, this only happens once per server and is the same delay you see when logging into a desktop.  If the user has a disconnected session, this will be fast, otherwise it will take some time (This the difference between unlocking a screen and rebooting your computer and then logging in).

    You can help alleviate some of this by making sure disconnected sessions don't autolog out (This of course eats up more resources) and that by closing the last application the session stays disconnected rather than logging out.  Then users would only hit this big delay the first time they connect.


    The second delay, is the time that the application takes to spin-up and show UI, there is nothing you can do about this.


    The reason that the second and subsequent Apps start almost instantly, is that we are sharing the session when possible and so you don't have to login to the server and you just have the second delay (IE the time for the application to spin-up).


    Hope that makes it clear and you can plan accordingly.




    Wednesday, December 21, 2011 11:21 PM
  • Hi Kevin,

    That part makes sense. What I don't understand is the time it takes to login to the session when going to the desktop is about 10 seconds where as the time it takes to login to the session going to a remoteapp is about 20-25 seconds (and then another 4-5 to actually load the app). Any thoughts as to why those times would be so different?

    Thursday, January 5, 2012 8:07 PM
  • Hi all,

    I have no fix for the issue but I might give you some hints to where to look at.

    After you logon to the web, when you start your remote app you get prompted for logon credentials. Once entered, it takes exactly 30 seconds before getting redicted to the RD Host server (hosting the app).

    You can monitor your connection on your RD Gateway in Remote Desktop Services -> RD Gateway Manager -> Host name -> Monitoring. You will notice that as soon as you logon, your connection shows in the list. But until it hits 30 seconds, nothing gets transmitted to the RD Host.

    I have no clue what is going on during these 30 seconds but I can see our firewall connecting to the RD Host at the exact moment you authenticate.

    So I don't know what the gateway does during these 30 seconds but it is not passing traffic to the RD Host.

    Hope this helps.

    Friday, January 13, 2012 1:53 PM
  • I finally found my 30 second delay from this link:


    I use a WMI filter to determine 32 bit and 64 bit OS.  I found the query took about 4 seconds on the 2008 R2 server, and it ran 8 different times for various different group policies.  When I removed those group policies, it only took a couple of seconds to logon.  Now I have to figure out a new way to determine OS, but the 30 second delay is gone for me.

    Friday, February 3, 2012 6:48 PM
  • Hi,

    I have this problem too.

    I watched the start procdure in the server, and found that most of the time is wasted in the creation of process rdpshell.exe. The rdpshell.exe is created by process rdpinit.exe. When rdpshell.exe is created, my application is created at almost the same time. But the creation of rdpshell.exe is always delayed for about 20s by rdpinit.exe. I think this is just the reason why login is so slow. After rdpshell.exe is created, it is alive through the session life time. So, the subsequent application load is quickly.

    But why rdpshell.exe is delayed to be created is still unkonwn.


    Monday, October 8, 2012 7:57 AM
  • I too am having the same problem when launching RD RemoteApp applications via an RD Gateway.  I un-ticked the "Bypass RD Gateway server for local addresses" on the Session hosts + modified the file "C:\Windows\Web\RDWeb\Pages\en-US\Desktops.aspx - RDPstr += "gatewayusagemethod:i:1\n";" on RD Gateway servers.  However, I still have about a 20 second wait when launching the first RemoteApp application.

    Please reply if anyone has a solution.

    Monday, November 12, 2012 6:50 AM
  • Hi, i have same problem on 25-30 different locations. I think this is by design and that it must be like this, or?
    Friday, January 18, 2013 2:51 PM
  • Hi, i have same problem on 25-30 different locations. I think this is by design and that it must be like this, or?

    Not by design.  It just most likely caused by something in the Remote Desktop Server startup process.  You just have to figure it out, not that troubleshooting is easy.

    I started by moving my server into a "clean" OU in Active Directory, with no group policies assigned.  Once I did that, it was extremely fast.  So for me I had to then figure out which group policy caused delays.  I eventually figured out that my WMI calls were getting executed on every processor.  Since my server has 8 processors, the delay was 8 times worse than the same delay on my workstations.

    One other time I had startup script/login script delays.  I modified the scripts to write the current time at various places in the script to narrow down what line in my scripts was taking so long.

    Other times, the delay comes from something that has to wait for a timeout (DNS lookups are notorious for a 30 second timeout delay).

    In the end, it can be difficult to troubleshoot.  The key for me was to realize that I treated the server differently in Active Directory (since my regular workstations had no problems), so I started with looking at those differences.

    Oh -- and just in case you don't realize -- the initial RemoteApp connection does a hidden login/desktop/launch application procedure.  So all your login scripts/login process/drive mappings/user group policies will have to process before the application can launch.

    Friday, January 18, 2013 4:40 PM
  • if RDS hosts are NLB enabled i think a solution - at least works for me

    • on RDS host open RDS host configuration
    • open RD Connection Broker properties
    • on the bottom 'select IP address for reconnection' - by default i had local IP. i changed to NLB IP and voila! works as a devil

    i'am not sure how that influence redundancy but AFAIK NLB+Broker should do the trick.

    -o((: Leliv

    Wednesday, February 13, 2013 2:59 PM
  • Hi

    I had similar problems.

    For me a TCP-port was showing up on my firewall, between the GW and SH, TCP

    I added that port and now its running smoothly.

    Anyone know why 60825?


    • Edited by Robban Eriksson Tuesday, March 26, 2013 11:43 AM
    • Proposed as answer by Rinusripsus Thursday, July 18, 2013 1:55 PM
    • Unproposed as answer by Rinusripsus Thursday, July 18, 2013 1:55 PM
    • Proposed as answer by ADC-Paul Tuesday, July 23, 2013 9:17 PM
    Tuesday, March 26, 2013 11:43 AM
  • Win 2012 server; RDWEB, RDBROKER, RDHOST

    Internet explorer, rdweb page load: less than 1 second.

    Login: less than 2 seconds. Show list of published apps

    Click application: about 1.5 minutes to popup/show application. Only during the last 5 seconds, the details button was active, showing that the application startup was not the problem. Subsequent apps only couple of seconds

    Solution: apparently rdweb had no internet access due to proxy setting / DMZ firewall rules. The rdweb needs internet access to check certificate. See http://www.360ict.nl/blog/slow-startup-of-remote-applications/.

    Now total time is reduced to 20-30 seconds total, which is acceptable for us. I only don't understand why this certificate check is necessary for private applications.

    I have spent couple of days to find out, after trying a hundreds of suggestions...

    Good luck to all

    • Proposed as answer by MrFoppa Tuesday, October 8, 2013 8:33 AM
    • Unproposed as answer by MrFoppa Tuesday, October 8, 2013 8:33 AM
    • Proposed as answer by shamowfski Thursday, December 4, 2014 4:32 AM
    Thursday, July 18, 2013 2:21 PM
  • Changing RD Gateway settings worked for me. Just uncheck "Automatically detect RD Gateway server settings" and go for "Do not use an RD Gateway server".
    Tuesday, October 8, 2013 8:37 AM
  • Hi. 

    I've been struggling with this also a few years really .

    It's always the first login that takes  very long time. It's as if the IIS need to be woken up. I did see a message today about the Gateway not using the same certificate as IIS (for some reason ) and I added the correct one . Hopefully it'll solve it. The thing , once you've successfully logged in , you'll have to wait until the problem reappears. It's as if  the Application Pool would go to sleep or something. 

    Using simply RDP from MAc or Wndows or Android works perfectly , it's just the RDWEBB login that's the problem really. 

    I've playing arounf also with the new RD client for MAC and using the Remore Resources and it works great , assuming the firts login doesn't take forever . Once you succeeded , it works great on both MAC and Android (it think it was released about a month ago and I do recommend having a look at it. 

    I've checked so that is not our intrusion prevention software doing anything weird and it isn't (we use Syspeace to handle brute force, dictionary atacks and login attempts to automativcally handle them  and I also highly recommend you guys have a look at it also . ) 

    //Juha Jurvanen 

    Thursday, November 28, 2013 12:31 PM
  • Yesterday, I sat down with this issue again. 

    Douible, triplechecked the WMI rights, reset WMI Reporsiry (that actuall made things worse since a lot of other stuff stoped worjing .. not recommended really) , checked the COM permissions, networking connectivity , certiifcates, intrusion prevention ( Syspeace ) , removed and readded to local groups, tried changing permissions for RDWebaccess user . Still no luck. The symptoms were that from time to time, the RD Web either was extermely slow to login to or that all Remote APP Icons just disappeared. For no apparent reason, They were just gone and basically only a reboot would solve it. That was not an acceptable solution since it need to be running 24/7.

    Finally I decided that it must an IIS issue and changed the Application pool security to use "Local system" , did a IISRESET and so far it's been working like a charm actually. I think I'll go ahead and do it on all the other RD Web Servers also actually. 

    // Juha Jurvanen . JufCorp

    Friday, November 29, 2013 11:11 AM
  • i resolved problem otherwise: 1. microsoft officaly discurage of using built-in NLB feature. it is not being developed since w2k3 and hardware balancer are adviced. 2. RD has a broker and if you look closely to broker behaviour... NLB is not required at all. every time you connect to any machine, req is being redirected to broker to decide where to connect. taking those two i simply removed NLB configuration and used DNS RR. it's working fast and stable. all other scenarios - proposed here and other i tired - worked for some time and then failed back to described delays for no reason. personally i dicurage of using windows NLB in general but in RDS Farm particularly. this component should be treated as laboratory.

    -o((: Leliv

    Friday, November 29, 2013 12:53 PM
  • My environment is all 2012R2, 1xDC,1xGW,1xTS

    After fighting with this for a day or so, I resolved my issue by un-checking the box for "Bypass RD Gateway server for local addresses" within my RDS deployment.

    It was taking approx. 2 minutes to connect, now its approx. 7 sec.  Remote App or Remote Desktop, both fast externally and internally.

    Hope this helps.


    Tuesday, January 28, 2014 9:22 PM
  • Thanks, Rinus....

    This was our issue.

    Thursday, December 4, 2014 4:32 AM
  • Hi, also try disabling client health check on the gateway....that took a big bite out of my application initialization lag
    Saturday, December 5, 2015 10:51 PM
  • Hello,

    it seems like slow upload speed will affect the login for remoteapp.

    i've used it in office with 10Mbps upload/download. seems ok around 30secs.

    but one of our customer using 0.7Mbps upload and 10Mbps download it take's up to 1-2min to login.

    is there a way to optimize this?

    Monday, February 15, 2016 10:04 AM
  • Two things I recommend. Search the registry for any entries named stubpath and delete. Also use mandatory profiles.
    Wednesday, November 23, 2016 2:43 PM