When you create a new C# WCF Workflow Service Application in Visual Studio 2012 that targets .NET Framework 4.5, you may notice errors similar to the following in the Error List when the project is first created or opened:

Error 1 The type or namespace name 'Data' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 2 The type or namespace name 'Linq' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 3 The type or namespace name 'ServiceModel' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 4 The type or namespace name 'Data' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 5 The type or namespace name 'Linq' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 6 The type or namespace name 'ServiceModel' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 7 The type or namespace name 'ServiceModel' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 8 The type or namespace name 'Data' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 9 The type or namespace name 'Linq' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 
Error 10 The type or namespace name 'ServiceModel' does not exist in the namespace 'System' (are you missing an assembly reference?)
 C:\WFProjects\SampleWFService\SampleWFService\Service1.xamlx 0 0 



To resolve the errors, press Ctrl+Chift+B to build the project, or close and re-open the workflow designer.