Problem statement

GALSync configuration halts on the execution of the export on the AD MA.
FIM throws an error "stopped-server" on export.

Symptoms

Eventviewer

Log Name:      Application
Source:        Application Error
Date:          1/17/2013 9:38:58 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      FIMServer.domain.local
Description:
Faulting application name: mmsscrpt.exe, version: 4.1.3114.0, time stamp: 0x50ad5a10
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
Exception code: 0xc0000005
Fault offset: 0x0000000000053fcc
Faulting process id: 0x568
Faulting application start time: 0x01cdf4ea0fdebb1d
Faulting application path: C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin\mmsscrpt.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 88bd4904-60dd-11e2-b03f-005056910162
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
 
<System>
   
<Provider Name="Application Error" />
   
<EventID Qualifiers="0">1000</EventID>
   
<Level>2</Level>
   
<Task>100</Task>
   
<Keywords>0x80000000000000</Keywords>
   
<TimeCreated SystemTime="2013-01-01T00:00:00.000000000Z" />
   
<EventRecordID>1531</EventRecordID>
   
<Channel>Application</Channel>
   
<Computer>FIMServer.domain.local</Computer>
   
<Security />
 
</System>
 
<EventData>
   
<Data>  </Data>
   
<Data>4.1.3114.0</Data>
   
<Data>50ad5a10</Data>
   
<Data>ntdll.dll</Data>
   
<Data>6.1.7601.17725</Data>
   
<Data>4ec4aa8e</Data>
   
<Data>c0000005</Data>
   
<Data>0000000000053fcc</Data>
   
<Data>568</Data>
   
<Data>01cdf4ea0fdebb1d</Data>
   
<Data>C:\Program Files\Microsoft Forefront Identity Manager\2010\Synchronization Service\Bin\mmsscrpt.exe</Data>
   
<Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
   
<Data>88bd4904-60dd-11e2-b03f-005056910162</Data>
 
</EventData>
</Event>

Troubleshooting Steps

Uncheck Exchange provisioning on the ADMA and see if it works out.
Then try to test RPS URI from the FIM server in PowerShell.
If it doesn't work there is an issue with the RPS URI.

Resolution

  1. Check the RPS URI configuration, use the FQDN instead of simple server name.
    Eg. replace http://exchsvr/powershell with http://exchsvr.mycompany.com/powershell
  2. Check the RPS URI can be reached

See Also