You can use the Graph Tool to graphically display the results of key performance tests such as the Winsock, USB, and Bluetooth performance tests. The Graph Tool can be run from within the Windows Embedded Compact Test Kit (CTK) or from the console command line. You can use the console version of the Graph Tool if you are running the supported performance test through Platform Builder and not the Windows Embedded Compact Test Kit (CTK). Use this method to process the perf results log and generate the graph. For more information on the console option, see Running the Graph Tool as a Console Application below.

The Graph Tool can be run from within the Windows Embedded CTK in two different ways: integrated as part of viewing the results for a test or run directly from the Tools menu.

Viewing Performance Test Results Graphically

The Graph Tool can be run from within the Windows Embedded CTK as part of the process of viewing test results for the Winsock, USB, and Bluetooth performance tests.

To view performance test results graphically:

  1. In the Windows Embedded CTK, connect to a device. For more information, see Connecting to a Device.
  2. Open a performance test, such as the Winsock Performance Test. For more information, see Running the Winsock Performance Test.
  3. On the File menu, point to Open, and then click Test Pass.
  4. In the Open dialog box, select a test pass file and then click Open.

Note   If a test pass was already in the Test Pass display window, you'll be asked if you want to save the current test pass before a new test pass is created.

  1. In the Test Pass display window, select the checkboxes of the test cases or test case nodes you want to run.
  2. On the Test menu, click Run Test Pass, or press the F5 key.
  3. Once the test pass has completed running, click on the View Results for the Selected Test Pass icon in the toolbar or right-click on the individual test and click View Results.
  4. On the Common Results View window tab, in the Test Pass Results table, double-click the test results row for the successfully complete performance test.
  5. On the Graphical Results View window tab, in the Test Case Results History table, in the Graph View column, click the document icon.
  6. In the window that opens, view the test results data in graphical format.

Running the Graph Tool from the Tools Menu

In addition to the Graph Tool running within the Windows Embedded CTK as part of the process of viewing test results, the Graph Tool can be run directly from the Tools menu.

To run the Graph Tool from the Tools menu

  • In Windows Embedded Compact Test Kit, on the Tools menu, click Graphical Results View.
  • In the Graphical Performance View dialog box, on the Simple tab, do the following:
    • In the Test Dll Name list, select the configuration file for the type of performance test results to graph. For example, if you are graphing the Winsock Performance Test results, select perf_winsock2.
    • Click the Open Notebook icon to view the selected configuration file.
    • Next to Input File, click the Open Folder icon.
    • In the Add File dialog box, select the input log file to use for graphing data.
    • Change the folder path in Output or keep the default path.
  • (Optional) Click the Advanced tab to add the following additional features to your graph:

To add this optional feature

Do the following

To graph how performance varies over time

  • Select Trend Analysis to graph multiple logs.
  • Next to Input File(s) click the open folder icon.
  • In the Add File dialog box, select an input log file to use.
  • Click Add more logs to add more input logs for the trend analysis. You can use a maximum of 10 input log files.

To graph multiple logs using one test log as a benchmark

  • Next to Input File(s) click the open folder icon.
  • In the Add file dialog box, select an input log file to use.
  • Click Add more logs to add more input logs.
  • Next to Benchmark File click the open folder icon.
  • In the Add file dialog box, select an input log file to use as a benchmark.

To run Microsoft Excel once the graphs are drawn

Select Launch Excel. This option is selected by default.

To output graphs in an MIME HTML (MHTML) web page archive format

Select mht.

To output graphs as JPEG image files

Select Images.

To select a line, plotted point, or bar graph

Select Graph Type.

To set the font size

Select a Font Size.

 After setting the options, you can do one of the following:

  • Click the Run to generate graphs.
  • Click Reset to reset to the default setting.
  • Click Close to exit.

Running the Graph Tool as a Console Application

In addition to running the Graph Tool from within the Windows Embedded Compact Test Kit (CTK), you can run the Graph Tool as a console application.

To run the Graph Tool from the console command line:

  • Open a command prompt window.
  • Navigate to the folder where the Graph Tool is installed. The default location is:

 C:\Program Files\Windows Embedded Compact Test Kit\GraphTool\bin\.

Note: By default the Graph Tool configuration files are located in

C:\Program Files\Windows Embedded Compact Test Kit\GraphTool\ConfigFiles\.

Type the following command, replacing placeholder text in with your specific test information:

GraphToolConsole.exe -c <config_file> -i <input_log_file> -t <test_dll_name>

Graph Tool Command-Line Parameters

This section describes the usage syntax and command-line parameters for the Graph Tool console application.

GraphToolConsole -c <Graph Tool Config File>  -i <Input File> -t <Test name>

     [-o <Output File(xlsx)>] [-b <Benchmark file>][-trend][-image <path>][-ct <Chart Type>][-XlLaunch][-mht <Output File(mht)>][-font <Font Type>]

Command Line Parameter Description
-c  <Graph Tool Config File> (Input) Path to the graph tool configuration file(xml)
-t  <Test name> (Input) Test DLL name from used tp generate logs
-i  <Input file> (Input) Input log file(s)
[-o <Output excel file>] (Output)Path to the output graph file(.xlsx) (optional)(By default saves as Graphs.xlsx in base directory)
[-b <Benchmark file>] (Input) Benchmark file (optional)
[-trend] (Input)  Enables trend analysis (optional)
[-image <Path>] (Output) Saves graphs as JPEG images at specified path (optional)(By default images are saved in base directory)
[-mht  <Output mht file>] (Output) Saves graphs as web page(mht) at specified path (optional) (By default saves as Graphs.mht in base directory)
[-ct    <Chart Type>]

Chart type to be plotted (optional)

  1. Smooth curve with markers
  2. Smooth curve
[-font   <font Type>]

Font Type  (optional)

  1. Small font type
  2. Medium font type
  3. Large font type
[-XlLaunch] Opens the output excel file(optional)

  Note: If path for the input file(s) not specified, the base directory will be treated as the default path.

 Examples:

 >GraphToolConsole -c ConfigFile.xml -t perf_winsock2 -i perf.LOG -image

 >GraphToolConsole -c ConfigFile.xml -o graph.xlsx -i perf.LOG -t perf_winsock2

 >GraphToolConsole -c ConfigFile.xml -o graph.xlsx -t perf_winsock2 -i perf.LOG

 >GraphToolConsole -c ConfigFile.xml -i perf.LOG -t perf_winsock2 -image -ct 2 -XlLaunch

 >GraphToolCo -t perf_winsock2 -c ConfigFile.xml -i perf.LOG -image c:\images\ -ct 2

 >GraphTool -c ConfigFile.xml -i perf.LOG -mht graphs.mht -t perf_winsock2 -ct 2 -font 1 -XlLaunch


See Also