duvidaA função SE é, na minha opinião, uma das funções mais importantes do Excel. É ela que permite ao usuário estabelecer condições e, com isso, definir caminhos diferentes em seus cálculos.

Exemplificando, podemos ter em uma célula o valor do salário e em outra o valor do imposto de renda, que será calculado APENAS SE o salário for superior a um piso qualquer.

Eu sempre recomendo que, quando uma fórmula precisar seguir “DETERMINADAS CONDIÇÕES“, ela seja, primeiramente, DESENHADA NO PAPEL, isso mesmo, NO PAPEL, À MÃO! Com o tempo ganhamos experiência e podemos pular essa etapa. O correto planejamento desse tipo de fórmula garante seu sucesso.

Tentarei explicar, da uma forma bastante simplificada e direta, o raciocínio básico da construção de uma fórmula usando a função SE.


Projetando no Excel a fórmula que terá a função SE

Sempre que temos DUAS opções, precisamos tomar UMA decisão. Se estamos seguindo por uma estrada e encontramos uma bifurcação, temos que escolher um dos caminhos. Alguma característica (ou conjunto delas) determinará a nossa decisão.

Então, trazendo para o nosso modelo, a função SE é estruturada pela presença de TRÊS argumentos, e pode ser representada pelo seguinte modelo:

=SE(TESTE_LOGICOCAMINHO ACAMINHO B) ou exemplificando:

=SE(IDADE<18; “MENOR”; “MAIOR”)

Fazendo-se a leitura estruturada da sintaxe acima, temos:

SE IDADE MENOR QUE 18 ENTÃO

MENOR

SENÃO

MAIOR

FIM

Observe que temos duas opções de resposta para o problema: MENOR ou MAIOR. Como eu disse agora há pouco, se tenho que escolher entre DUAS hipóteses, basta fazer UM teste. Essa regra se aplica a amostras maiores: se tenho 5 hipóteses, resolverei com 4 testes.Sempre teremos UM teste a menos que o número de hipóteses. Essa é a regra geral.

Então, criemos agora um exemplo prático do uso da função SE.

No modelo abaixo temos uma ficha, bastante simplificada, para calcular o líquido a receber de um funcionário.

MODELO_BASE

Prestem utilizaremos aqui três desses campos:

  • SALÁRIO (será digitado pelo usuário)
  • VALE REFEIÇÃO (valor fixo de 200 reais SE O SALÁRIO FOR SUPERIOR A R$ 5.000,00)
  • LÍQUIDO A RECEBER: SALÁRIO – VALE REFEIÇÃO.

Nesse caso temos duas opções: COBRAR R$200,00 ou COBRAR ZERO. A decisão dependerá do valor do salário.

Desenhamos abaixo o nosso problema e traduzimos para a fórmula final:

ARVORE1

Portanto, basta inserirmos a fórmula =SE(I5>5000;200;0) na célula I7 para calcularmos o desconto de VALE REFEIÇÃO.

ESCREVENDO_SE_1

Pronto. Conforme podemos ver na ilustração abaixo, temos o desconto de R$ 200,00 referentes ao vale refeição condicionado ao salário. Alterem o valor do salário para algo inferior a R$ 5.000,00 e vejam que não haverá desconto de vale refeição.

MODELO_FINAL

 

Espero que curtam esse artigo e, acreditem, esse conhecimento poderá trazer muitos frutos.
Para fazer o download do modelo utilizado, CLIQUE AQUI.

Estou aqui, à disposição, aceitando sugestões para novos artigos.