SharePoint 2010: MsiInstaller errors while attempting to manage a User Profile Service Application

Issue

while managing the User Profile services you get warning in the event viewer post restarting the IIS.

Error

Detection of product '{90140000-104C-0000-1000-1000000FF1CE}', feature 'PeopleILM', component '{1C12B6E6-898C-4D58-9774-AAAFBDFE273C}' failed.  The resource %programfiles%\Microsoft Office Servers\14.0\Service\Microsoft.ResourceManagement.Service.exe' does not exist.

Or

Detection of product '{90140000-104C-0000-1000-1000000FF1CE}', feature 'PeopleILM' failed during request for component '{1681AE41-ADA8-4B70-BC11-98A5A4EDD046}'

Or

Failed to connect to server. Error: 0x80070005.

 

Background 

Many time we have seen these error keeps on recorded in event viewer after our servers either patched or we do an IIS following any change in the server of the SharePoint Web App.

It was not having any business impact, however keep on flooding the event viewer leading to miss some important error and information.

Troubleshooting: I did not bang my head much on this as I have got KB article which support this behavior completely and  KB says that this issue happens when you attempt to manage the User Profile Service Application via Central Admin on a SharePoint Server 2010 with the User Profile Synchronization service started after an IISReset, the following warnings are logged in the application log of the SharePoint server:

Resolution

Grant the Network Service account read access to the %programfiles%\Microsoft Office Servers\14.0 folder.

Reference

 MS KB supporting this behavior http://support.microsoft.com/kb/2473430

Credits

http://mossnwss.blogspot.co.uk/2014/08/sharepoint-2010-msiinstaller-errors.html

Applies to

  •  Microsoft SharePoint Server 2010