Symptoms

Although FIM Service and FIM are using the same build, FIM Sync fails to connector FIM MA to the portal.

 


Error messages

Sync Engine

When you try to connect the FIM MA to the FIM Service, you get the following error message:

Failed to connect to the specified database.

Failed to connect to the specified database or Forefront Identity Management Services.

Please check the specified database location, service host address, and account information.

mmsmafim: MIIS.ManagementAgent.ManagedMAConnectionFailureException: The Forefront Identity Manager Management Agent does not support the current Forefront Identity Manager Resource Management Service database version.

   at MIIS.ManagementAgent.RavenMA.InitializeConnection(XmlNode connectionInformationNode, XmlNode encryptedAttributeNode, Boolean runInitialization)

   at MIIS.ManagementAgent.RavenMA.UIInitialize(String pszInitString, Int32& pfValid, String& ppszResult)

 

Event viewer

mmsmafim

Log Name:      Forefront Identity Manager Management Agent

Source:        ForefrontIdentityManager.ManagementAgent

Date:          4/29/2015 6:39:40 AM

Event ID:      3

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      CONTOSOSRV02.CONTOSO.COM

Description:

mmsmafim: MIIS.ManagementAgent.ManagedMAConnectionFailureException: The Forefront Identity Manager Management Agent does not support the current Forefront Identity Manager Resource Management Service database version.

   at MIIS.ManagementAgent.RavenMA.InitializeConnection(XmlNode connectionInformationNode, XmlNode encryptedAttributeNode, Boolean runInitialization)

   at MIIS.ManagementAgent.RavenMA.UIInitialize(String pszInitString, Int32& pfValid, String& ppszResult)

Event Xml:

 
  <System>
 
    <Provider Name="ForefrontIdentityManager.ManagementAgent" />
 
    <EventID Qualifiers="0">3</EventID>
 
    <Level>2</Level>
 
    <Task>0</Task>
 
    <Keywords>0x80000000000000</Keywords>
 
    <TimeCreated SystemTime="2015-04-29T13:39:40.000000000Z" />
 
    <EventRecordID>24</EventRecordID>
 
    <Channel>Forefront Identity Manager Management Agent</Channel>
 
    <Computer>CONTOSOSRV02.CONTOSO.COM</Computer>
 
    <Security />
 
  </System>
 
  <EventData>
 
    <Data>

mmsmafim: MIIS.ManagementAgent.ManagedMAConnectionFailureException:

The Forefront Identity Manager Management Agent does not support the current Forefront Identity Manager Resource Management Service database version.

   at MIIS.ManagementAgent.RavenMA.InitializeConnection(XmlNode connectionInformationNode, XmlNode encryptedAttributeNode, Boolean runInitialization)

   at MIIS.ManagementAgent.RavenMA.UIInitialize(String pszInitString, Int32&amp; pfValid, String&amp; ppszResult)</Data>

  </EventData>

</Event>

 

FIM MA

Log Name:      Forefront Identity Manager Management Agent

Source:        ForefrontIdentityManager.ManagementAgent

Date:          4/29/2015 6:39:40 AM

Event ID:      3

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      CONTOSOSRV02.CONTOSO.COM

Description:

The Forefront Identity Manager Management Agent does not support the current Forefront Identity Manager Resource Management Service database version.

Event Xml:

  
  <System>
  
    <Provider Name="ForefrontIdentityManager.ManagementAgent" />
  
    <EventID Qualifiers="0">3</EventID>
  
    <Level>2</Level>
  
    <Task>0</Task>
  
    <Keywords>0x80000000000000</Keywords>
  
    <TimeCreated SystemTime="2015-04-29T13:39:40.000000000Z" />
  
    <EventRecordID>23</EventRecordID>
  
    <Channel>Forefront Identity Manager Management Agent</Channel>
  
    <Computer>CONTOSOSRV02.CONTOSO.COM</Computer>
  
    <Security />
  
  </System>
  
  <EventData>
    <Data>The Forefront Identity Manager Management Agent does not support the current Forefront Identity Manager Resource Management Service database version.</Data>
 
  </EventData>
 
</Event>

Database mismatch

Log Name:      Forefront Identity Manager Management Agent

Source:        ForefrontIdentityManager.ManagementAgent

Date:          4/29/2015 6:39:40 AM

Event ID:      3

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      CONTOSOSRV02.CONTOSO.COM

Description:

The current version of database is not compatible with the one expected by Forefront Identity Manager service. The current version of the database is : 1116. The expected version is : 1117.

Event Xml:

 
  <System>
 
    <Provider Name="ForefrontIdentityManager.ManagementAgent" />
 
    <EventID Qualifiers="0">3</EventID>
 
    <Level>2</Level>
 
    <Task>0</Task>
 
    <Keywords>0x80000000000000</Keywords>
 
    <TimeCreated SystemTime="2015-04-29T13:39:40.000000000Z" />
 
    <EventRecordID>22</EventRecordID>
 
    <Channel>Forefront Identity Manager Management Agent</Channel>
 
    <Computer>CONTOSOSRV02.CONTOSO.COM</Computer>
 
    <Security />
 
  </System>
 
  <EventData>
 
    <Data>The current version of database is not compatible with the one expected by Forefront Identity Manager service. The current version of the database is : 1116. The expected version is : 1117.</Data>
 
  </EventData>
 
</Event>


Solution

Install the latest hotfix on the FIM servers.

 


Background info

This situation can happen when a database restore has put the databases in a more recent version than the installed software version.