Hoje vamos passar um case de solução desenvolvido em equipe, no qual, passamos por dois problemas ao mesmo tempo, um conjuntos de soluções foi implementando, e desta forma, fora resolvido

Error 500 when login ECP and OWA (Erro interno do Servidor)

Alguns passos que podem ser realizados em casos como estes:

  1. 1 - %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i e Recycle do MSExchangeOWAAppPool;
  2. 2 - ADSIEDIT.msc e not configured no nos canários;

Link completo da Solução e Créditos:

https://social.technet.microsoft.com/wiki/contents/articles/34020.exchange-2013-troubleshooting-error-500-when-login-ecp-and-owa.aspx

 

Em nosso caso, não foi possível a solução completa e precisamos também realizarmos outra ações:

  •  Inserir em Grupos do Exchange: Exchange Domain Servers, Exchange Enterprise Servers, Exchange Servers, Exchange Trusted Subsystem, Exchange Recipient Administrators, PB Exchange Server Administrators

Uma vez realizadas esse conjuntos de ações acima, o erro 500 resolver mas nos apresentou o erro 400 abaixo.

Situação02: exchange 2013 owa error 400 Bad Request

  1. Logar no Servidor Exchange 2013 CAS server;
  2. Iniciar o Exchange Management Shell;
  3. Ir no Exchange 2013 binaries
    1. C:\Program Files\Microsoft\Exchange Server\V15\Bin\
    2. Executar UpdateCas.ps1 Windows PowerShell script and aguardar alguns minutos.  Este script vai rebuild em sua interface OWA.

Desta forma com todas as ações acima, o problema fora resolvido.

Criadores da Solução: André Gonçalves, Christian Centeno e FOL!