Mapped drive will not disconnect


  • I have a computer running Windows 7 Enterprise with a network drive mapped to another commuter running Windows XP Professional. The C drive in the computer with XP went bad and the computer was replaced. However I cannot disconnect the mapped drive.

    If I try to disconnect it using the context menu option in Windows Explorer it brings up a dialog box that says, "This network connection does not exist," and does not disconnect it. I have also tried to disconnect it from the command line:

    C:\>net use Z: /delete
    The network connection could not be found.
    More help is available by typing NET HELPMSG 2250.
    C:\>net helpmsg 2250
    The network connection could not be found.

    This problem is very annoying. Please help.

    Tuesday, October 11, 2011 12:42 AM


All replies

  • In cmd windows, you can directly type command 'net use' to see the net connection.

    If the Z: doesn't existed in the list, 'the network connection could not be found' is normal.

    And you can directly define a new network location to Z:.

    Tuesday, October 11, 2011 7:45 AM
  • It still showed up in the list but would not let me disconnect it. However, it replaced it just fine. Thank you.

    • Proposed as answer by Kevin M. Covert Thursday, November 21, 2013 9:58 PM
    Tuesday, October 11, 2011 2:14 PM
  • once you replace you can delete the mapped drive now..
    Regards, h9ck3r.
    Tuesday, October 11, 2011 5:09 PM
  • I was experiencing a similar problem on my computer. The root of the issue is that the drives where initially mapped when explorer.exe was started. As you said, after "disconnecting" them they still appeared in My Computer but not "net use". Restarting explorer.exe at this point removed the drives from My Computer.
    • Proposed as answer by Skills Friday, July 06, 2012 9:44 PM
    Friday, April 13, 2012 1:23 PM
  • That's the ticket! KISS! (Keep It Simple Stupid) I remember this from my Novell instructor. I am definitely going to put this in my HOW TO's Thank you Robert Greer!
    • Edited by Skills Friday, July 06, 2012 9:46 PM
    Friday, July 06, 2012 9:44 PM
  • This worked for me as well. 

    Thanks Robert!

    Monday, July 23, 2012 8:07 PM
  • I've tried both solutions, I've tried remapping the drive (net use Z: \\myServer\myShare\), restarting explorer and the computer. It still shows the disconnected drive and I can't delete it. Anybody else have this issue? Thanks.

    Thursday, March 14, 2013 8:05 PM
  • I have a similar issue on Server 2012, but when net use is run it shows "There are no entries in the list." but shows in Windows Explorer. Restarting Server and explorer.exe does not change anything?!
    Tuesday, April 09, 2013 6:50 AM
  • I have a client running Windows 7 connected to SBS 2011 Essentials. Mapped drives to previous server persist as icons in Windows Explorer and can't be deleted even though I used net use to delete the drive letter mappings. I have been able to map new letters to the shared folders on the new server but can't get rid of the red X icons no matter what I try, including the suggestion to net use the same drive letter and then try and disconnect.

    Any suggestions would be appreciated!



    Friday, April 26, 2013 5:01 PM
  • I tried all described above, but nothing worked. But somewhere I found that "Net Use /Persistent:yes" would set all current drives to persistent. I tried "Net Use /Persistent:no", booted and that one driveletter was gone at last. May be that will do the trick for you????

    Leo Koolsbergen

    • Proposed as answer by rbdsolutions Thursday, May 09, 2013 4:44 AM
    Thursday, May 02, 2013 6:52 AM
  • Microsoft: There are multiple bugs here, at least to the rest of the world.  Please correct them anyway. 

    -> If 'net use' reports no drives, neither should Explorer. 

    -> A refresh in Explorer should remove the disconnected drives, if 'net use x: /delete' alone doesn't do it -- but it should.

    -> The Explorer context menu 'Disconnect' should remove them also.

    Monday, July 15, 2013 5:20 PM
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    • Proposed as answer by TonyVov Saturday, July 27, 2013 1:52 AM
    Saturday, July 27, 2013 1:51 AM
  • I have tried this but no luck - I still see Disconnected Network Drive (V:) in explorer. Also tried a restart and settings /persistent:No and Yes.

    Is there any place I can escalate this to Microsoft and not be charged Pro Support fee for?

    Sunday, July 28, 2013 10:32 PM
  • the batchfile worked great. 


    Marcia Henry

    Friday, September 06, 2013 2:14 AM
  • Was having a similiar issue and this little batch file worked like a charm!


    • Proposed as answer by tommmyyyyyyyy Monday, November 23, 2015 3:53 PM
    Friday, October 04, 2013 3:25 PM
  • I have the same issue on Win 7. This drive is our home drive from AD.

    The one factor I see is that all other drive mappings show as "Microsoft Windows Network" whereas this one mapping shows as NFS network. Perhaps this has something to do with it.

    I can map the drive as letter Z and it works. It is mapped as drive P and will not allow me to access. System error 85.

    Status       Local     Remote                    Network

    OK           J:        \\t70nas301\home\jpanik   Microsoft Windows Network
    OK           N:        \\T01FAP01\ISDATA         Microsoft Windows Network
                    P:        \\t70nas301\home\JPANIK   NFS Network
    OK           Q:        \\T70NAS301\PUBLIC\PUBLIC Microsoft Windows Network
    OK           R:        \\T70NAS401\SHARED\SHARED Microsoft Windows Network
    OK           S:        \\T70NAS301\SHARED        Microsoft Windows Network
    OK           Z:        \\t70nas301\home\jpanik   Microsoft Windows Network
    The command completed successfully.

    Thursday, October 31, 2013 7:03 PM
    In HKEY_CURRENT_USER\Network the key for the drive does nto exist.
    Exported one of the other keys for a drive mapping and edited the content to match that of my locked drive.

    "ProviderName"="Microsoft Windows Network"

    add this to a REG file and merge the data.
    Once this is done, click the drive mapping and the error is that the drive is not available, you can now disconnect the mapping.

    • Proposed as answer by Jimm Panik Thursday, October 31, 2013 7:10 PM
    Thursday, October 31, 2013 7:10 PM
  • Just log-off or restart the system it will go off.
    Wednesday, November 06, 2013 1:17 PM
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.

    DOS Vader

    • Proposed as answer by Whizzy42 Tuesday, October 28, 2014 5:29 PM
    Friday, December 06, 2013 9:14 PM
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.

    DOS Vader

    Worked for me as the mapped drive was created using Task Scheduler with user System. Was unable to get rid of the share unless I umount it with a script just as I mounted it (nfs share). +1
    Monday, December 16, 2013 6:46 AM
  • it works! thanks a lot
    Monday, February 03, 2014 11:55 AM
  • The easiest way to fix this problem is to edit the regedit , it so simple.

    open regedit

    Go to HKEY_CURRENT_USER/Network

    Now remove the letter you want in this case X, and restart the computer. issue is fixed.

    Sunday, February 16, 2014 11:20 AM
  • There appear to be a multitude of people with the same issue and a multitude of solutions offered by others.  I tried just about all of them but to no avail, including all the registry changes, net use commands, rebooting, restarting Explorer etc etc.  In the end, the only solution that allowed me to actually disconnect my network drive and remove it from displaying in explorer was the following:  remove the offending PC from the network Domain (ie. join a workgroup), login as a local administrator, then you can disconnect the offending drives.  Then re-register the PC to your Domain as per normal and you will find that the offending drives are gone and you can re-establish your required network mappings.
    Wednesday, March 05, 2014 6:21 AM
  • Thanks DOS Vader - yours was the only method that worked for me. Possibly because in my case the drive letter was mapped to a NAS share?


    Friday, March 28, 2014 6:28 PM
  • Thanks!  Worked.
    Monday, April 14, 2014 3:04 PM
  • @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe

    Working fine for me, keep mind to run it like administrator


    Tuesday, June 03, 2014 12:54 PM
  • Brilliant, this helped me resolve the issue.
    Tuesday, June 17, 2014 1:45 PM
  • This is a serious bug in Windows Explorer, and I'm very much surprised that Microsoft failed to address it for so long:
    All workarounds posted here or else where basically work by killing Explorer, or worse still by rebooting Windows. This is ridiculous :-(

    This bug has been in all versions of Windows since at least Windows XP. For example, here's a 2006 post that reports exactly the symptoms I'm having today with Windows 8:

    As in that 2006 example, I'm regularly affected by the consequence, where Windows Explorer reports the OLD share name (the one that refused to go away after the drive became disconnected) even after the same drive letter is mapped on a DIFFERENT share. This is really a serious issue, as this can potentially lead to data loss, by misleading the user to copy or erase data on the wrong shares!!!

    Mr Microsoft, how can we officially enter this bug in your bug tracking databases, and make sure that Windows Explorer gets fixed at last?
    (That means fixing the three symptoms of the problem reported by chiptech above, plus the fourth I report here.)
    (And please no more suggestions for workarounds. It's a fix preventing the issue from reoccuring that we need, not yet another time consuming method for repairing Explorer after it starts displaying false information.)


    Monday, July 07, 2014 10:30 AM
  • I was going to give this one a try but there are no entries under HKEY_CURRENT_USER\Network (I even added another mapping to see if one would show up - nope).
    Tuesday, August 19, 2014 3:13 PM
  • Leaving and re-joining the domain was my "last resort" - it didn't work either.

    Tuesday, August 19, 2014 3:15 PM
  • This was the one for us : running a scheduled task. Importantly I believe that this was because the network drive was created by the system account and ultimately regardless of enhanced permissions it would not delete as any other user.

    By simply running the scheduled task as that same system user I was able to remove the mapped drive through a scheduled task.


    Friday, August 29, 2014 5:54 PM
  • s this just a bug in explorer, I wonder. This is why:
    A user (win8.1) did not have, through an oversight, the rights to a certain share. So I made a mapping using different user-credentials, which at least provided the user with reading-rights. When the oversight had been corrected (the user now had read/write access to the share) I wanted to re-do the mapping. So i tried to delete it, but ran into the situation more-or-less as described here: in explorer, drive has red cross; in the registry, drive is not to be found; under 'net use', drive is not listed; in a cmd-window, drive does not exist. (By the way: if this is just an explorer issue, then how come the drive doesn't exist in a cmd-window?) Then I tried to just re-map the driveletter, this time using the user's own credentials, without first disconnecting. This SEEMED to work, but in fact, access was still read-only! Then - here it gets hairy - I tried mapping to that share using a different driveletter: the mapping was read-only! Suspecting that somehow first completely deleting the driveletter was essential, I tried most of the above tricks - to no avail.
    What finally worked was, especially under my 20/20 hindsight vision, very simple: first re-mapping the offending driveletter to a different share, then to the right share again. Not only did the drive have write-access, but now I could delete the mapping in the normal way by just disconnecting in win explorer.
    Friday, October 17, 2014 5:02 PM
  • DOS Vader's  scheduled Task option  

    This was the only solution that worked for me...

    Tuesday, October 28, 2014 5:28 PM
  • I used: "net use Z: /delete" and it did remove the drive. I even check HCU/Network and it was gone.

    History: Drive returned on its' own. Ran "net use" and it did not report anything. Ran "net use Z: /delete" and it said deleted. Ran "net use" and it did not report anything. Check HCU > Network and drive is gone. Restarted MyComputer and the drive is still there.

    I did a search of the entire registry for the drive's network name and it isn't there. Sure wish MS would take a few minutes off of Win10 and fix this problem with Win8.

    Thursday, November 13, 2014 11:18 AM
  • Thanks Tony

    I went to task manager>processes. Find Explorer.exe and end task. Next click applications tab, click NEW TASK type in Explorer.exe and click OK. you're done Drive was gone

    • Edited by justnuts69 Tuesday, December 02, 2014 3:38 PM
    Tuesday, December 02, 2014 3:25 PM
  • The batchfile described above didn't work on itself, but i implented one important command to it

    This will delete those "ghost"-netdrives. Create .cmd -file and paste text belowe to it, and run as an admin.

    Net Use /Persistent:no
    net use * /delete /y
    taskkill /f /IM explorer.exe

    Tuesday, December 09, 2014 8:05 AM
  • Proposed as answer by TonyVov Saturday, July 27, 2013 1:52 AM

    net use * /delete /y

    taskkill /f /IM explorer.exe

    You nailed it.  That was driving me crazy.  I tried everything else in this thread.  ONLY this worked and I needed to do all of the steps.


    Friday, January 02, 2015 2:09 PM
  • I support Henge's believe that the mapped drive was created by the SYSTEM account and can thus only be removed using the SYSTEM account.

    Instead of DOS Vader's scheduled Task, I however used SysInternals PSExec to Run a command as SYSTEM.

    psexec -s -i cmd
    net use Z: /delete /y
    • Proposed as answer by Kapil Patry Thursday, September 10, 2015 4:27 AM
    Thursday, March 05, 2015 4:19 PM
  • Thanks Robert. Restarting explorer fixed the issue. 
    Tuesday, March 10, 2015 2:22 PM
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.

    DOS Vader

    This is the first time I've ever responded to someone on technet, but it's because you are a genius. This perfectly fixed my problem. I'd created these drives as the system user so that Crashplan would see them and back them up. I don't need that anymore and my NAS has a new address, so I had undeletable drives. You fixed that! Bravo.
    Friday, September 04, 2015 2:51 PM
  • @ Ten Cents, This worked for me perfectly on a Windows Server 2012 R2. Earlier, I had tried all the solutions that were posted here in this forum and out there on the web but running psexec as a System process and deleting the mapped drive was a no problem at all. Thanks!!
    Thursday, September 10, 2015 4:29 AM
  • To remove the incorrectly labeled mapped drive, follow these steps:
    1. Click Start, point to Run, type regedit, and then click OK.
    2. In Registry Editor, locate the following registry subkey:
    3. Right-click the mapped drive that you want to remove. For example, right-click ##<var class="sbody-var" style="box-sizing:border-box;">Server_Name</var>#<var class="sbody-var" style="box-sizing:border-box;">Share_Name</var>, and then click Delete
    4.  Restart PC :-) 
    Thursday, September 17, 2015 7:01 AM
  • This registry edit was the only thing that worked for me. Thank you!!
    Saturday, October 31, 2015 7:27 PM
  • @ Ten Cents 

    thanks, run as SYSTEM is key to the issue for me.

    Wednesday, December 02, 2015 11:51 AM
  • I had 2 drives showing as disconnected with red crosses. I was unable to unmap in most of the ways suggested above. I was getting system error 85 or not found.

    The worrying thing was that when opened they still linked to a server share (the wrong one) and the user had R/W access to the root of the server's data drive, even though they were not an admin! I couldn't find any cached credentials. I assumed some kind of rogue software had done this.

    Using the task scheduler with SYSTEM rights, I managed to get rid of one of them.

    The 2nd one could only be got rid of through deleting the MountPoints2 registry key as described here.

    Thanks a lot.

    • Edited by trichromic Friday, January 29, 2016 2:14 PM
    Friday, January 29, 2016 2:13 PM
  • I had this problem, all of the above did not work, turned out to be an application called CloudBerry Drive, it is used for Azure, Amazon etc. You need to unmount it from the app that created it, it is not managed by Windows 7,8, 8.1, 10 and so forth. IF not this, then something above should work. BTW, CloudBerry is a solid app, it was my mistake trying to manage it within Windows OS. There are many Network Drive app for local LAN's, Data Centre and Internet solutions, the question for yourself is; did I create it with Windows??, if YES and none of the above works, you probably have corruption, sorry to tell you that but some suggestions below. If NO, then go back to the app.

    The other thing to consider is that the network location cannot be reached, windows appears to hang when you click it or very slow to start File Explorer due to your Quick Access setting having Recent places monitored, look at; firewall, share deleted, NIC problem, IP Address changed via DHCP (changed or cannot be reached), default IP Addr instead of correct IP address (starts 169.254...), permissions have changed on the share/network drive location, PC not joined to the correct domain or none at all, a workgroup for the share has been created and you are not part of it.

    The Network Drive table is stored in; HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices use regedit if you are confident. In the Command Prompt (CMD) the net use command returns error 2 or 86 when you try to delete it if it is managed by another application outside of windows. If you created it with an app but have since uninstalled it then regedit is probably your only option: caution regedit can kill a machine, if you are not confident, take a backup before you start, if you fail and kill the machine then refresh windows is your only option if you didn't backup first.

    Tuesday, May 31, 2016 2:34 PM
  • Thanks, 

    This worked without rebooting. 

    Monday, July 11, 2016 9:21 PM
  • brilliant.  years ago I had set the z: to exist across boots and without logins for a service to use.  You jogged my memory and your commands solved me.  thanks!

    Jim S.

    Friday, July 29, 2016 7:03 PM
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    Finally this fixed the problem.  First I mapped the same drive with some other network folder.  I then created the batch file net_Use_delete.bat with the following commands:

    C:\Temp>notepad net_Use_delete.bat

       net use G: /delete /y
       taskkill /f /IM explorer.exe


    C:\Temp>net use G: /delete /y
    G: was deleted successfully.

    C:\Temp>taskkill /f /IM explorer.exe
    SUCCESS: The process "explorer.exe" with PID 3148 has been terminated.


    Finally the File explorer has deleted the G: drive information without rebooting the PC.

    Friday, August 05, 2016 1:00 AM
  • Hahar, hahaha!

    Microsoft Logic Bomb:



    Perfect... absoutely....... perfect Microsoft. Thank you soooooo.... much. Your developers prove, on almost every level, why some people should NOT indeed ever think about becoming developers.

    And unfortunately... they all appear to work for Microsoft. Maybe (after 30+ years of everyone else's misery) your H.R should really think about tightening their minimum IQ requirements.
    Saturday, August 27, 2016 7:08 PM